Remy

Sonic Generations: PC Discussion

256 posts in this topic

Yes I remember thinking the first cutscene looking pixelated compared to ingame, but not to the extent to where it would bother me. But the tv my pc's hooked up with isn't that big. I think around 32 inches

Edited by Djawed

Share this post


Link to post
Share on other sites

Anyone have the same graphics card as I do (GeForce 9400)? If so, how does it run at the lowest settings? SuperLink has a meh laptop, yet the game still ran on it.

Share this post


Link to post
Share on other sites

Anyone have the same graphics card as I do (GeForce 9400)? If so, how does it run at the lowest settings? SuperLink has a meh laptop, yet the game still ran on it.

Personally I wouldn't bother, this game looks nice on high settings at 60fps, anything below that just wouldn't do it justice. tongue.png

However if you're dead set on trying it out, there is a way to test it for "free",, not telling how though.

Edited by Silencer226

Share this post


Link to post
Share on other sites

Personally I wouldn't bother, this game looks nice on high settings at 60fps, anything below that just wouldn't do it justice. tongue.png

However if you're dead set on trying it out, there is a way to test it for "free",, not telling how though.

I'm not pirating it :\

I'm really getting just so I can play both the HD and Nintendo version. I could care less about the lag or graphics.

Share this post


Link to post
Share on other sites

Hoopsie~ Can't believe I posted in a locked topic!

On my new laptop I have NVIDIA GeForce GT 540M installed and driver up-to-date, but when I configure Sonic Generations, it only allows me to choose Intel® HD Graphics Family. Is this how it should be? (I am trying to adjust some settings because when I have a non-wide configuration it goes smooth enough, but I want to use all of the screen and then it tears.) x3

Might also be worth mentioning that I can play games like Half-Life 2 and Left 4 Dead 2 very smoothly, but I dunno if those games can compare to Sonic Generations graphic-wise, I am so bad at this! =D

Found another post which might describe my situation better:

Hey guys, not sure if this is the right place to post or not, but Sonic Generations won't recognize my second graphics card.

This is on my laptop. My two cards are:

1) Intel HD Graphics Family

2) NVIDIA GeForce GT 540M

Sonic Generations, in the configuration menu, can't detect my GeForce GT card. It only shows my Intel card as the only graphics card. Now with the Intel card, I'm able to play it, but not too well. There's a bit of button delay and the frame rate isn't the best.

Considering I can play games like Battlefield 3 and Assassin's Creed just fine, it's a little annoying I can't run Sonic Generations.

Does anyone have any idea?

I read up about connecting to a monitor through HDMI will magically make the graphic card compatible, but it still does not show up for me. T.T

Share this post


Link to post
Share on other sites

The specs that people are posting, I think I can run it at full spec. Because 8GB of Ram, AMD Hexacore 2.8GHZ and GTX 550TI card overclocked makes me a very happy man <3

Share this post


Link to post
Share on other sites

Hoopsie~ Can't believe I posted in a locked topic!

On my new laptop I have NVIDIA GeForce GT 540M installed and driver up-to-date, but when I configure Sonic Generations, it only allows me to choose Intel® HD Graphics Family. Is this how it should be? (I am trying to adjust some settings because when I have a non-wide configuration it goes smooth enough, but I want to use all of the screen and then it tears.) x3

Might also be worth mentioning that I can play games like Half-Life 2 and Left 4 Dead 2 very smoothly, but I dunno if those games can compare to Sonic Generations graphic-wise, I am so bad at this! =D

Found another post which might describe my situation better:

I read up about connecting to a monitor through HDMI will magically make the graphic card compatible, but it still does not show up for me. T.T

Got the same problem, and so do a bunch of other people on the Steam forums. You can force the game to use the GeForce card, but then the game will say the config tool doesn't match your current hardware (because the config tool only detects the Intel card). Besides the HDMI fix which only works for some people, there is no fix at the moment. SEGA really needs to fix this ASAP.

Share this post


Link to post
Share on other sites
Might also be worth mentioning that I can play games like Half-Life 2 and Left 4 Dead 2 very smoothly, but I dunno if those games can compare to Sonic Generations graphic-wise, I am so bad at this! =D

Don't forget, Valve has had 7 years after initial release to fine-tune and optimize their Source Engine, compared to Sonic Team's 3 years to do the same to their Hedgehog Engine. At the same time Valve is frequently patching their games/software where it seems Sonic Team likes to release it and forget it tongue.png

As for the CPZ issue everyone is having, people seem to be pinpointing it on Havok as apparently the game really only lags during segments with numerous physics effects like water (why oh why did I not shell out for PhysX!?!)

Share this post


Link to post
Share on other sites

Got the same problem, and so do a bunch of other people on the Steam forums. You can force the game to use the GeForce card, but then the game will say the config tool doesn't match your current hardware (because the config tool only detects the Intel card). Besides the HDMI fix which only works for some people, there is no fix at the moment. SEGA really needs to fix this ASAP.

Ah, that's what's going on with the Nvidia Geforce cards...hopefully Sega does fix this soon.

Share this post


Link to post
Share on other sites

Is it wrong that I feel genuinely sorry for people who have to experience this on consoles compared to PC?

The difference is utterly mindblowing. I completed the game on PC while I waited for my CE to arrive in the post, and my jaw was dropped throughout most of the game. It's stunning. Beautiful. I'd even go as far to say that I think it's the best looking game I've ever played. Sure, there's a few texture issues here and there, but overall the attention to detail is amazing!

...then I played the 360 version, which looked dull and horribly pixelated (especially the cutscenes, they just looked unforgivably pixelated) in comparison. All on the same screen (I use my TV as a monitor), so it's a fair comparison.

Share this post


Link to post
Share on other sites

I'm wondering if SonGen will run on my laptop, since I refuse to buy it if it won't work.

Here are my specs:

unledvf.png

Please help.

Share this post


Link to post
Share on other sites

There was a work-around for NVIDIA cards - You can connect it to an external monitor with a HDMI connection, and it might detect the NVIDIA graphics card. This however does not work for me. D; They better fix this soon. I am not playing Sonic Generations on a framerate of 5 and input lag.

Share this post


Link to post
Share on other sites

Hoopsie~ Can't believe I posted in a locked topic!

On my new laptop I have NVIDIA GeForce GT 540M installed and driver up-to-date, but when I configure Sonic Generations, it only allows me to choose Intel® HD Graphics Family. Is this how it should be? (I am trying to adjust some settings because when I have a non-wide configuration it goes smooth enough, but I want to use all of the screen and then it tears.) x3

Might also be worth mentioning that I can play games like Half-Life 2 and Left 4 Dead 2 very smoothly, but I dunno if those games can compare to Sonic Generations graphic-wise, I am so bad at this! =D

Found another post which might describe my situation better:

I read up about connecting to a monitor through HDMI will magically make the graphic card compatible, but it still does not show up for me. T.T

I know what's going on, but I'm not sure how to fix it. (you'll probably know some of this alread) Your laptop has both integrated and discrete graphics and switches between them as required because the integrated chip uses less battery power. I think I know how to fix it based on a video I watched demoing how this stuff works, I recall there being an option within the context menu of.exe files that allows you to force one adapter or the other. I think that if you go to

C:\Program Files (x86)\Steam\steamapps\common\sonic generations

and then right click on ConfigurationTool.exe and then I think there should be an option to get it to run using the discrete (the 540) chip. I think there might also be an option to make it the default. You might have to do the same to the game's main .exe.

EDIT: OH WAIT!! You need to add that option to the context menu. This done through the Nvidia control panel. Open the nvidia control panel (right click on the desktop and select it), then go to view and check "add run with graphics processor to context menu".

Edited by Phos

Share this post


Link to post
Share on other sites

I'm no longer getting a configuration error. A patch somehow fixed that. However, the configuration is still saying I can't use my Geforce card.

While I thank Phos for trying to help, I can't find the function he mentioned while visiting the control panel.

Thank you to Dizney for telling how to use an external monitor as a temporary fix, by the way...I can't access one, but that's still pretty cool for people who can. ^_^

Share this post


Link to post
Share on other sites

Picked this up on Steam for £20, already got my money's worth out of it. As just mentioned, anyone having problems should double-check again because a new patch went live about 45 mins ago. Unfortunately I couldn't find a changelog anywhere so I don't know what's been fixed.

I'm going to try turning off AA and seeing what that does to my FPS (even though my FPS is almost always a smooth 60) but there are noticeable lag spikes. Based on what I experienced firsthand, it's the Hedgehog Engine being both dumb and clever at once; it streams textures on the fly midlevel, and each time there's a lagspike and slowdown it's loading up the next set of textures. This is particularly obvious in Chemical Plant Act 2, and note the frequency of the level features and lighting changing there; more than they do in any other level actually. That also means there's no fix for it, folks, because it's part of the level design.

By the way, this same feature malfunctioning is why you get the invisible floor/objects bug in Green Hill as well; there seems to be a specific route through the level that's missing its texture loading trigger and/or can have it bypassed by mistake. Silly programmers. (Again, that means there's no fix unless they patch it, and it only happened to me once anyway.) I can't find the thread this was mentioned in but at least one other person had this issue, so I thought I'd clear that up whilst I could.

It's nice to see what this graphics engine can do when it's got some actual modern horsepower behind it, and I dread the idea of playing the 360 version for comparison now. Especially as my PC has surround sound. Delicious surround sound. n_n

Tailer likes this

Share this post


Link to post
Share on other sites

EDIT: OH WAIT!! You need to add that option to the context menu. This done through the Nvidia control panel. Open the nvidia control panel (right click on the desktop and select it), then go to view and check "add run with graphics processor to context menu".

I already seem to have that option activated, and I attempted to start both the configuration and Sonic Generations itself with the Nvidia card that way, but I just crashed with the good ol' "hardware doesn't work, bugger off!" ;9

As just mentioned, anyone having problems should double-check again because a new patch went live about 45 mins ago. Unfortunately I couldn't find a changelog anywhere so I don't know what's been fixed.

I did notice the patch being installed, but it did not fix anything for me, and a restart of Steam or a reboot of my laptop did not help much either. However, I feel we are coming closer toward a fix, and I just cannot wait! :3

Share this post


Link to post
Share on other sites

Mmph. Bought this shit today.

I've been ambivalent at best towards this game up 'till now, but seeing the game in action after its release got me a little interested, and saving 20 bucks on Steam means I can't go wrong.

It's gonna take the whole day to install it, so here's hoping it works out fine.

Share this post


Link to post
Share on other sites

Alright guys, I've beaten up to Planet Wisp, all with all S-ranks and all red rings, excluding mission (saving those for last). Been playing the PC version on my brother's computer. I seem to have run into a few issues. Though from what I've been reading in places, slowdown in CPZ is normal. But at other random parts, the game slows down, pauses/freezes temporarily or even crashed a few times. Anyone else been having these issues?

It's definitely not the computer's fault. Computer has 4GB of RAM, a quad core CPU (which is definitely good enough for the game and more), and a pretty awesome GPU to boot. Most of the time, the game runs flawlessly at 60FPS on highest resolution, on max settings. So other than these issues, the game itself is very solid, especially since I've been using a 360 controller. Mosty been avoiding missions, but I have been getting the character missions out of the way. They're pretty terrible.

...maybe it's partially the fault of my brother using 32-bit vista because he never installed Windows 7 64 bit?

Share this post


Link to post
Share on other sites

Alright guys, I've beaten up to Planet Wisp, all with all S-ranks and all red rings, excluding mission (saving those for last). Been playing the PC version on my brother's computer. I seem to have run into a few issues. Though from what I've been reading in places, slowdown in CPZ is normal. But at other random parts, the game slows down, pauses/freezes temporarily or even crashed a few times. Anyone else been having these issues?

It's definitely not the computer's fault. Computer has 4GB of RAM, a quad core CPU (which is definitely good enough for the game and more), and a pretty awesome GPU to boot. Most of the time, the game runs flawlessly at 60FPS on highest resolution, on max settings. So other than these issues, the game itself is very solid, especially since I've been using a 360 controller. Mosty been avoiding missions, but I have been getting the character missions out of the way. They're pretty terrible.

...maybe it's partially the fault of my brother using 32-bit vista because he never installed Windows 7 64 bit?

Nope, you're definitely not alone on this one. And I have Windows 64-bit version installed.

Share this post


Link to post
Share on other sites

I'm no longer getting a configuration error. A patch somehow fixed that. However, the configuration is still saying I can't use my Geforce card.

While I thank Phos for trying to help, I can't find the function he mentioned while visiting the control panel.

Thank you to Dizney for telling how to use an external monitor as a temporary fix, by the way...I can't access one, but that's still pretty cool for people who can. happy.png

<- It's one of the first things he does in this video, though Dizney's response makes me wonder if it'll work.

I already seem to have that option activated, and I attempted to start both the configuration and Sonic Generations itself with the Nvidia card that way, but I just crashed with the good ol' "hardware doesn't work, bugger off!" ;9

weird. Sonic Team isn't usually a PC developer, so I imagine they're not used to dealing with so much hardware. However, nowadays most laptops with decent graphics have Nvidia Optimus so I imagine they'll fix it.

Share this post


Link to post
Share on other sites

Ah, that's my problem, my version of Nvidia does not have a view menu in the control panel. Thank you very much for trying to help, though, Phos. ^_^ I do feel better at least having clearer idea of the problem. :)

I guess we'll just have to wait until an Nvidia Optimus fix shows up. I'll probably have to turn the quality of the graphics down in order to play, but I'd much rather do that than not play at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.