Jump to content
241

Application Error (0xc0000142) when trying to load Sonic Generations PC

Recommended Posts

First of all, I just got my new laptop (Toshiba Satellite S855D) that runs on Windows 8. It has AMD A10-4600M for the CPU and the GPU is AMD Radeon HD 7660G (which is integrated with the CPU; not dictated). Sonic Generations runs on my computer perfectly when playing with low resolutions (640 x 480, 800 x 480, 800 x 600, 1024 x 600, 1024 x 768) and details.

 

Anyway, when CPKREDIR is enabled (which allows me to play Sonic Generations with mods), I tried running SonicGenerations.exe, and suddenly an error message shows up:

 

 

The application was unable to start correctly (0xc0000142. Click OK to close the application.

 

That error is fixed when CPKREDIR is disabled, but I can't use the mods! angry.png Is there a way to fix that error to  run SonicGenerations.exe properly with mods enabled? (If yes, can you come up with a solution?) Has anyone experienced this error mentioned above? I'm a noob BTW because I really can't figure out with the error.

 

Thanks in advance! smile.png

Share this post


Link to post
Share on other sites

Use Sonic GMI instead of CPKREDIR, then delete a very small file that's name starts with 'GraphcisConfig' in Program Files > Steam > steamapps> common> Sonic Generations. I forgot the file type. Finally go to the configurations tool and save the settings. Hope that helped.

Share this post


Link to post
Share on other sites
Use Sonic GMI instead of CPKREDIR, then delete a very small file that's name starts with 'GraphcisConfig' in Program Files > Steam > steamapps> common> Sonic Generations. I forgot the file type. Finally go to the configurations tool and save the settings. Hope that helped.

I tried that method, but when I run SonicGenerations.exe it still gives me an error. sad.png

Share this post


Link to post
Share on other sites
First of all, I just got my new laptop (Toshiba Satellite S855D) that runs on Windows 8. It has AMD A10-4600M for the CPU and the GPU is AMD Radeon HD 7660G (which is integrated with the CPU; not dictated). Sonic Generations runs on my computer perfectly when playing with low resolutions (640 x 480, 800 x 480, 800 x 600, 1024 x 600, 1024 x 768) and details.

 

Anyway, when CPKREDIR is enabled (which allows me to play Sonic Generations with mods), I tried running SonicGenerations.exe, and suddenly an error message shows up:

 

 

 

That error is fixed when CPKREDIR is disabled, but I can't use the mods! angry.png Is there a way to fix that error to  run SonicGenerations.exe properly with mods enabled? (If yes, can you come up with a solution?) Has anyone experienced this error mentioned above? I'm a noob BTW because I really can't figure out with the error.

 

Thanks in advance! smile.png

I don't know reinstall sonic gmi and cpkredir huh.png , I don't have much to say to you, because A. I am a no good piratedry.png (with a legit xbox 360 copy biggrin.png  and a not so legit pc copysleep.png ) I can use mods fine thoughlaugh.png B. Generations runs at a snail's pace on my laptop C. I have windows 7 

Share this post


Link to post
Share on other sites

I guess this error is caused by cpkredir.dll, extracted from the cpkredir040.zip file, so I replaced with the same DLL file from cpkrdir031.zip, run SonicGenerations.exe with mods enabled and runs perfectly without error. Problem solved. smile.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

You must read and accept our Terms of Use and Privacy Policy to continue using this website. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.